[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] problem in starting xend

  • To: "Gautham Kampalapur Shankar, TLS, Chennai" <gauthamk@xxxxxx>
  • From: Nico Kadel-Garcia <nkadel@xxxxxxxxx>
  • Date: Mon, 29 Oct 2007 12:31:33 +0000
  • Cc: xen-users@xxxxxxxxxxxxxxxxxxx
  • Delivery-date: Mon, 29 Oct 2007 05:31:10 -0700
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=beta; h=received:message-id:date:from:user-agent:mime-version:to:cc:subject:references:in-reply-to:content-type:content-transfer-encoding; b=YTnfAGODdnghcJgsUBOLpngbpd7/TDbgxuvkua8xklpxyV5jvzDweYkwIxRWBIB1siaVFpku4V6Hhwb/hy45rZcrtey7rcbfhZOBQNvxxhP0zCy34kN5BX/8QzEEhRNd9u2JFPAPo+6WZ6Pxf74tEeCQQpP6THT+9DpI/C9NfrU=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

Gautham Kampalapur Shankar, TLS, Chennai wrote:

-----Original Message-----
From: Nico Kadel-Garcia [mailto:nkadel@xxxxxxxxx]
Sent: Mon 10/29/2007 4:25 PM
To: Gautham Kampalapur Shankar, TLS, Chennai
Cc: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-users] problem in starting xend

Gautham Kampalapur Shankar, TLS, Chennai wrote:
> I tried to install xen, but got some errors when starting xend.
> as I logged in and tried to start xend
> (/etc/init.d/xend start). I just got six-seven dot (.) printed out,
> then it
> stops. I looked more closely and found that xend could not start.
> then I looked at /var/log/xend-debug.log. here is the last few lines:
> ^^^
>    Exception starting Xend: no element found: line 1 coloumn 0
> ^^^
> and i guess the problem is because of /etc/init.d/xend scripts in
> await_daemons_up function or it may be failed because of other
> reasons. anybody experienced this
> problem, or know how to fix this?
> thanks gautham
How did you install Xen? What OS, and which version? Did you install and
reboot with a Xen compatible kernel?

i am using xen-3.1.0. and using it on linux-2.6.18 debian kernel.
- untared the source, then "make world", then "make install". everything was fine
- configure grub for xen
- reboot the machine..

as far as booting is concerned i have booted correct xen compatible kernel

it was working fine for 2-3 days, i could run the xend and boot the domU also. but once it has reported the problem of No Space Left error on the device... so i created some space for this purpose. after creating the space, i got this annoying error.

Exception starting Xend: no element found: line 1 coloumn 0..

final  message before this annoying message was
Exception starting xend:(28, 'No Space left on device');

i hope i am clear...

So, you're using Debian, a locally compiled Xen, and a local file based Xen image installation.

What does "df" say on your Dom0? Did you by chance generate a "sparce" file to put your Xen guest on?

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.