[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Trouble with PCI Passthrough

2012/10/7 Dariusz Krempa <imperiaonline4@xxxxxxxxx>

2012/10/6 David Escott <david.escott@xxxxxxxxxxxxxxxx>
Passthrough seems to be the most common problem, but I don't know enough of
the voodoo magic to understand where to start investigating my issue,
which is that passthrough works but only when passing through multiple

dom0: Fedora 17 with stock XEN (a later 4.1 version and a 3.5 kernel)
Hardware: VT-d capable MSI Z77 w/ i7-3770
Graphics cards:
      Intel HD 4000 IGD set as primary in the bios and used by dom0
      Radeon HD2600XT (from 2005ish) PCI-E slot 1, PCI 0000:01:00.[0,1]
      Radeon 7850 (brand new)              PCI-E slot 3, PCI 0000:02:00.[0,1]

What works:
    dom0 with the HD4000 IGD
    domU Windows 7 when both Radeon cards are passed through
              ie stubbing out 0000:01:00.[0-1] and 0000:02:00.[0-1]
and giving both to Win7

What doesn't work (and what I dont understand):
    domU Win7 when only one of the two devices is passed to Windows
(in which case I get the error 43) [tried it both ways, passing only
the 2600 or only the 7850, and same error either way]

Given that passthrough works, I dont understand why it would not work
when I only pass one of the devices. Is there something I should be
looking at (DMA ranges? IRQs?) to determine what linkage there is
between these two devices?


David Wright Escott
A comathematician turns cotheorems into phi.

Xen-users mailing list

Try to setup in bios Radeon as the first card, then in grub add xen-pciback.hide=(2:00.0)(1:00.0)

menuentry 'Ubuntu GNU/Linux, with Xen 4.2.1-pre and Linux 3.6.0-rc7-xen' --class ubuntu --class gnu-linux --class gnu --class os --class xen {
        insmod lvm
        insmod part_msdos
        insmod ext2
        set root='(ubuntu-root)'
        search --no-floppy --fs-uuid --set=root db446272-d70f-43c8-a355-0aeeba6a70dd
        echo    'Loading Xen 4.2.1-pre ...'
        multiboot       /boot/xen-4.2.1-pre.gz placeholder  
        echo    'Loading Linux 3.6.0-rc7-xen ...'
        module  /boot/vmlinuz-3.6.0-rc7-xen placeholder root=/dev/mapper/ubuntu-root ro  splash quiet xen-pciback.hide=(1:00.0)(2:00.0)
        echo    'Loading initial ramdisk ...'
        module  /boot/initrd.img-3.6.0-rc7-xen

When I'm using hd4850+gtx560 and I want to passthrough gtx560 i have to setup it as first, in other way it not work. I'm hiding just one card, (1:00.0) in my case, and when Dom0 starts they just switchiing. I have Dom0 on hd4850 and DomU on gtx560.

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.