[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] GTX 670 Tips?

  • To: Casey DeLorme <cdelorme@xxxxxxxxx>, Gordan Bobic <gordan@xxxxxxxxxx>
  • From: David TECHER <davidtecher@xxxxxxxx>
  • Date: Sun, 27 Oct 2013 09:14:41 +0000 (GMT)
  • Cc: "xen-users@xxxxxxxxxxxxx" <xen-users@xxxxxxxxxxxxx>, Andrew McGlashan <andrew.mcglashan@xxxxxxxxxxxxxxxxxxxxx>
  • Delivery-date: Sun, 27 Oct 2013 09:16:01 +0000
  • Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=s1024; d=yahoo.fr; h=X-YMail-OSG:Received:X-Rocket-MIMEInfo:X-Mailer:References:Message-ID:Date:From:Reply-To:Subject:To:Cc:In-Reply-To:MIME-Version:Content-Type; b=5Qa+/1P1AKII2bJO/utCRoQuCRiR4jr2npiqseuWBDLuCyxFhg7XfNY4cNJDBbMJLWxK+h1ooNNwe83tOvObtt7P+tu0N+3TcO0fx4r7c97y35vhyDt77Ecg0kmB5RUq73dyhU7X8IRvk/lx/5ILSAGS7SvokuJ191flZ5/6nqg=;
  • List-id: Xen user discussion <xen-users.lists.xen.org>

I installed Ubuntu 12.04 yesterday and Linux mint 15 a couple weeks ago using my card hard-moded to GRID K2 and it works perfectly with NVIDIA drivers.

You have to

- install Linux
- black list nouveau ( info provided below)
- install NVIDIA drivers and


a) Content of my shell script to start domU could be found here http://pastebin.com/6DYec0jM

You may have to update those lines

declare -r PCIdevices="0000:01:00.0 0000:01:00.1 0000:00:1a.0 0000:00:1d.0";
# The list of PCI devices which are to be re-enabled.
declare -r EnableDevices="0000:01:00.0 0000:01:00.1";

I am not the original author of this script. You can find the original script at ftp://ftp.enjellic.com/pub/xen/run-passthrough.

b) Content of my domU conf file is there http://pastebin.com/1ZsN0muJ

Here is what I did for Ubuntu (may works for any Linux distro)

1.  While installing set gfx_passthru=0. You need to install Ubuntu from another PC through usual VNC (xen)
vnc hostname_of_your_dom0

2. Once Ubuntu is installed you are asked to reboot. Click on button 'Restart'. There might be several glitches on the screen...Just press 'ENTER'...There might be a printed message asking to click on 'ENTER' but due to glitches on the screen it is a bit hard to guess that you are asked to press 'ENTER'. Just press 'ENTER'

3. Once domU is restarted. Log in your domU using VNC from your other PC. Blacklist nouveau.

sudo su
echo "blacklist nouveau" >> /etc/modprobe.d/blacklist-nouveau.conf

apt-get update
apt-get install vim openssh-server

vim /etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT="quiet nouveau.blacklist=1 splash"


update-initramfs -u


Once domU is rebooted
log into your domU through ssh

ssh IP_of_your_domU

stop X
service lightdm stop # Ubuntu 12.04
service mdm stop # Linux mint 15

download nvidia driver
# 32 bit
wget http://uk.download.nvidia.com/XFree86/Linux-x86/331.17/NVIDIA-Linux-x86-331.17.run
# 64 bit
wget http://uk.download.nvidia.com/XFree86/Linux-x86_64/331.17/NVIDIA-Linux-x86_64-331.17.run

Install it

chmod +x NVIDIA????.run

Once done, power off the domU


Log into your dom0, set gfx_passthru=1

restart your domU.

It works for NVIDIA drivers serie 319.XX

Le Dimanche 27 octobre 2013 8h40, Casey DeLorme <cdelorme@xxxxxxxxx> a écrit :
I'm pretty sure gfx_passthru=1 doesn't work without additional patches to do things like load and execute the VBIOS in domU.

Yeah I saw the flag mentioned, but wasn't sure if it was in the context of "windows only" or linux also.  From the sound of things that flag works with qemu traditional only, with modded cards and no patches.

So you get VNC video during installation, and you get external output from the card from the nouveau driver. So far so good.

FYI, the noiveau driver isn't _too_ bad. If all you need is 2D acceleration, I can confirm that an ageing 8800GT with nouveau driver is perfectly capable of running HD video scaled up to 3840x2400 (2x1920x2400 across 2 monitors).

Yes, I only got video from the emulated card during install, but the first and all subsequent boots show terminal through the GTX 670.  I know the nouveau isn't bad for 2D, but I was hoping to try various 3D Accelerated applications in linux with passthrough, so I need the proprietary drivers.

Remind me - did you modify your card into a Quadro/Grid?

I'm sure I remember David mentioning he had Linux domU running with accelerated drivers.

The card is modded to Grid K1 (Linux sees it as GK104).

I tried the `nvidia-kernel-dkms` package, and have also tried the latest downloaded drivers (3.19.60 http://www.nvidia.com/object/unix.html).  Neither worked, when I installed from the downloaded package it said it was built for gcc 4.6 and could be incompatible.  It appeared to still install, but again no video.

Xen-users mailing list

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.