[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Arch linux PV guest won't boot

>Which version of Xen are you using?


I've made a bit of progress.  I'm not 100% sure why the log files were
zero bytes previously, though I just increased the memory for dom0
since dmesg showed it was running out and killing processes.  In
anycase, here is what I'm getting in /var/log/xen/bootloader.XX.log:

Traceback (most recent call last):
  File "/usr/lib/xen/bin/pygrub", line 886, in <module>
    raise RuntimeError, "Unable to find partition containing kernel"
RuntimeError: Unable to find partition containing kernel

Now I tried editing the vm conf file to use xvda.  But no matter xvda
or hda I get the same error message above.

When during the loading/booting process is that error thrown?  Is Xen
even finding my grub file?
If it is finding the grub file is there a chance I'm not using the
right UUID?  Below is grub.cfg and what I have in my /etc/fstab file.


root@archiso /mnt/boot/grub # cat grub.cfg
menuentry 'Arch GNU/Linux, with Linux core repo kernel' --class arch
--class gnu-linux --class gnu --class os $menuentry_id_option
'gnulinux-core repo kernel-true-b0f4f817-984e-4863-8951-abd3a6bded4e'
        insmod gzio
        insmod part_msdos
        insmod ext2
        set root='hd0,msdos1'
        if [ x$feature_platform_search_hint = xy ]; then
          search --no-floppy --fs-uuid --set=root
--hint-bios=hd0,msdos1 --hint-efi=hd0,msdos1
--hint-baremetal=ahci0,msdos1  b0f4f817-984e-4863-8951-abd3a6bded4e
          search --no-floppy --fs-uuid --set=root
        echo    'Loading Linux core repo kernel ...'
        linux   /boot/vmlinuz-linux
root=UUID=b0f4f817-984e-4863-8951-abd3a6bded4e ro
        echo    'Loading initial ramdisk ...'
        initrd  /boot/initramfs-linux.img
root@archiso /mnt/boot/grub # cat /mnt/etc/fstab
# /etc/fstab: static file system information
# <file system> <dir>   <type>  <options>       <dump>  <pass>
# /dev/mapper/arch-root
UUID=b0f4f817-984e-4863-8951-abd3a6bded4e       /               ext4
         rw,relatime,data=ordered        0 1

# /dev/mapper/arch-home
UUID=caaa2c09-2b2d-4b8e-b33d-69b122aaee81       /home           ext4
         rw,relatime,data=ordered        0 2

On Tue, Oct 14, 2014 at 3:36 PM, Ian Campbell <ian.campbell@xxxxxxxxxx> wrote:
> On Mon, 2014-10-13 at 23:34 +0800, H C wrote:
>> Hi,
>> I have Xen installed and running several (win 7) HVMs.  I've setup an
>> Arch linux PV guest but I am having a problem booting it. (The install
>> image booted fine.) After each failed attempt to boot I try to view
>> the /var/log/xen/bootloader.XX.log file but all of these files are
>> zero bytes.  So, I'm having some trouble troubleshooting this.  I
>> followed the instructions from
>> https://wiki.archlinux.org/index.php/xen on setting up an Arch PV and
>> do not think I missed anything.
> Which version of Xen are you using? ISTR older versions of xl couldn't
> handle pygrub on image backed disks, but I don't recall when this
> changed. This is fixed in more modern ones it requires a qemu process in
> dom0 -- this is now started by the xencommons initscript.
>> disk = [ '/vm/arch1/arch1.img,,hda,w', '/vm/img/ARCH_201410.iso,,hdb,cdrom']
> I'm not sure what hda means to a PV guest, maybe nothing bad would
> happen but it would be more usual to use xvda (likewise for hdb).
>> My understanding is that pygrub will take care of booting as long as
>> /boot/grub/grub.conf exists and is setup correctly which I believe I have 
>> done.
>> I copied the sample grub.conf from
>> "Xen - ArchWiki"(https://wiki.archlinux.org/index.php/xen)
>> and used the UUID for "/" found in /etc/fstab (its the same I get from blkid)
>> The wiki mentions that without certain modules in /etc/mkinitcpio.conf
>>  the VM will not boot.  But I've added them as shown below.
>> So I'm not sure why I'm getting the above error.
> One thing you can try is running pygrub by hand on the filesystem image,
> which might get some additional logs (which really ought to be captured,
> but perhaps they aren't for some reason).
> You can also invoke GrubConf.py (on my system it is
> in /usr/local/lib/python2.7/dist-packages/grub/GrubConf.py) passing it
> "grub2" and your grub.cfg and it should parse it and tell you the
> result. If that fails then it might give some clue what is going wrong.
> Ian.

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.