[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Arch linux PV guest won't boot

On Wed, 2014-10-15 at 02:20 +0800, H C wrote:
> >Which version of Xen are you using?
> 4.4
> I've made a bit of progress.  I'm not 100% sure why the log files were
> zero bytes previously, though I just increased the memory for dom0
> since dmesg showed it was running out and killing processes.  In
> anycase, here is what I'm getting in /var/log/xen/bootloader.XX.log:
> Traceback (most recent call last):
>   File "/usr/lib/xen/bin/pygrub", line 886, in <module>
>     raise RuntimeError, "Unable to find partition containing kernel"
> RuntimeError: Unable to find partition containing kernel
> Now I tried editing the vm conf file to use xvda.  But no matter xvda
> or hda I get the same error message above.
> When during the loading/booting process is that error thrown?

It comes from pygrub itself which is being run early on in the domain
construction process.

>   Is Xen
> even finding my grub file?

No, it appears it isn't even finding the partition which should contain

If you run "pygrub /path/to/disk.img" I expect it will report the same,
but can you please confirm.

It would also be useful to see the full logs from "xl -vvv
create /vm/arch1/arch1.conf".

> If it is finding the grub file is there a chance I'm not using the
> right UUID?  Below is grub.cfg and what I have in my /etc/fstab file.

These are in the guest? I don't think it is getting near to consulting

What does the partition table of your disk image look like? (You
provided a bunch of gdisk runes earlier, but I've no idea what they
would result in.


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.