[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] shared lib path errors

I looked at this update-rc.d tutorial: http://www.debuntu.org/how-to-managing-services-with-update-rc-d/ . It says installed services are enabled by default. So is 'xen installed via source build' an exception to that rule?Â

Also, none of the syntax examples match that shown in the update-rc.d commands in your original link ( https://dcvan24.wordpress.com/2014/01/24/install-xen-4-3-1-on-ubuntu-12-04-lts-from-source/ ). I am thinking the original commands are missing the "defaults" keyword, e.g. the first one should have been:

update-rc.d xencommons defaults 20 19

When I entered that command the results seem better, however I still get warnings I'm not sure if it is something to be concerned about:

update-rc.d: warning: default start runlevel arguments (2 3 4 5) do not match xencommons Default-Start values (2 3 5)
ÂAdding system startup for /etc/init.d/xencommons ...
ÂÂ /etc/rc0.d/K19xencommons -> ../init.d/xencommons
ÂÂ /etc/rc1.d/K19xencommons -> ../init.d/xencommons
ÂÂ /etc/rc6.d/K19xencommons -> ../init.d/xencommons
ÂÂ /etc/rc2.d/S20xencommons -> ../init.d/xencommons
ÂÂ /etc/rc3.d/S20xencommons -> ../init.d/xencommons
ÂÂ /etc/rc4.d/S20xencommons -> ../init.d/xencommons
ÂÂ /etc/rc5.d/S20xencommons -> ../init.d/xencommons

On Mon, Feb 23, 2015 at 10:04 AM, Wayne Mills <wmills.on.gm@xxxxxxxxx> wrote:
yeah those service were definitely 'stopped' ('-' symbol) according to 'service --status-all' output. Step 4 is an explicit step to change Xen process settings so that they come up at boot. I did not execute an equivalent step. Is that my issue? I tried one of those update-rc.d commands as listed but got a warning or error, not sure what to make of the output:

root@<server>:~# pwd
root@<server>:~# update-rc.d xencommons 20 19
update-rc.d: warning:Â start runlevel arguments (none) do not match xencommons Default-Start values (2 3 5)
update-rc.d: warning:Â stop runlevel arguments (none) do not match xencommons Default-Stop values (0 1 6)
usage: update-rc.d [-n] [-f] <basename> remove
ÂÂÂÂÂÂ update-rc.d [-n] <basename> defaults [NN | SS KK]
ÂÂÂÂÂÂ update-rc.d [-n] <basename> start|stop NN runlvl [runlvl] [...] .
ÂÂÂÂÂÂ update-rc.d [-n] <basename> disable|enable [S|2|3|4|5]
ÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂ -n: not really

The disable|enable API is not stable and might change in the future.

On Fri, Feb 20, 2015 at 2:46 PM, David Van Arnem <dvanarnem@xxxxxxxxx> wrote:
Hi Wayne,

I've only built Xen from source on Fedora (Red Hat distro), so I'm not sure if there are any additional steps needed for Ubuntu. You might check that the Xen services are running, specifically the ones in Step 4 on this page: https://dcvan24.wordpress.com/2014/01/24/install-xen-4-3-1-on-ubuntu-12-04-lts-from-source/


On 02/20/2015 12:29 PM, Wayne Mills wrote:
Hey David,

ok I rebooted, and on the grub screen I saw four choices:

* Ubuntu
* Advanced options for Ubuntu
* Ubuntu GNU/Linux, with Xen hypervisor
* Advanced options for Ubuntu GNU/Linux (with Xen hypervisor)

This screen vanished very quickly so I rebooted again and on my second try was able to arrow down to the third option and hit Enter. Theensuing screen output indicated it was booting the Xen-supporting kernel. However I'm still getting the same xl list error after logging in as root.

In case this helps: note that all I did prior to 'xl list' was to download xen source using git, then ./configure --enable-stubdom --enable-githttp, then make world and make install per the README file. I did also run 'ldconfig /usr/local/lib' per your suggestion. So if I'm missing other steps please advise. I haven't found a 'cookbook' on installing 4.5 source on 14.04 ubuntu ....... trying to things together from Debian-type help pages and other places.



On Fri, Feb 20, 2015 at 1:53 PM, David Van Arnem <dvanarnem@xxxxxxxxx> wrote:
Hi Wayne,

It looks like you have not booted into a kernel with Xen, so although XL is installed on your system, there is no Xen for it to communicate with. When you reboot, you should see kernel options on your Grub screen with Xen enabled, and you can boot into one of those and xl list should work.

If you don't see Xen enabled kernels on your Grub list, you'll need to update your Grub configuration, which I think on Ubuntu is done with update-grub.


On 02/20/2015 11:29 AM, Wayne Mills wrote:
Thanks David. That fix all my ".so not found" issues. I have now encountered a new error (see below). I'm new to the mailing lists so please let me know if I should start a different thread. I didn't spot this libxc error in the archives:

# xl list
xc: error: Could not obtain handle on privileged command interface (2 = No such file or directory): Internal error
libxl: error: libxl.c:109:libxl_ctx_alloc: cannot open libxc handle: No such file or directory
cannot init xl context


On Fri, Feb 20, 2015 at 1:01 PM, David A. Van Arnem <dvanarnem@xxxxxxxxx> wrote:
On 02/20/2015 10:44 AM, Wayne Mills wrote:

As part of a dev activity, I built Xen 4.5.0 from source and installed it successfully on my Ubuntu 14.04 server, However I am getting this error when running "xl list":

xl: error while loading shared libraries: libxlutil.so.4.3: cannot open shared object file: No such file or directory

Based on some archived threads, I verified the following.
--> This soft link & file exist in /usr/local/lib: libxlutil.so.4.3 -> libxlutil.so.4.3.0
--> /etc/ld.so.conf has this line: "include /etc/ld.so.conf.d/*.conf"
--> /etc/ld.so.conf.d/libc.conf has this content:
line 1: # libc default configuration
line 2: /usr/local/lib

Based on archived threads, xl should be searching /usr/local/lib based on the above. But it is obviously not. Meanwhile I tried linking the /usr/local/lib copy to /usr/lib. That worked (but now it's complaining similarly about not finding libxenlight). Not sure it matters but one final detail: echo $LD_LIBRARY_PATH from my shell shows nothing.

Are there any solutions recommended other than putting soft links in /usr/lib?


I don't know if this is the best solution, but in the past when I've encountered this error I used ldconfig and pointed to the location where my Xen libraries were installed (and then reboot). So for you, probably:

ldconfig /usr/local/lib

Xen-users mailing list

Xen-users mailing list

Xen-users mailing list

Xen-users mailing list

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.