[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Debugging DomU

  • To: Julien Grall <julien.grall@xxxxxxxxxx>, Ian Campbell <ian.campbell@xxxxxxxxxx>
  • From: "Chris (Christopher) Brand" <chris.brand@xxxxxxxxxxxx>
  • Date: Wed, 20 May 2015 23:48:29 +0000
  • Accept-language: en-US
  • Cc: xen-users <xen-users@xxxxxxxxxxxxx>
  • Delivery-date: Wed, 20 May 2015 23:48:56 +0000
  • List-id: Xen user discussion <xen-users.lists.xen.org>
  • Thread-topic: [Xen-users] Debugging DomU

Hi Julien,

>  I was asking if the kernel already setup his PT and enable pagination.

No, I don't believe it's gotten that far.

> The important CONFIG_* that should be enable are:
All of these were enabled except for one:
>         - CONFIG_ARCH_VIRT

I tried enabling that one, and it still ended up in the same state (as far as I 
can tell), but I saw two messages from Xen, too:
(XEN) traps.c:1757:d1v0 mcr p14, 0, r1, cr0, cr5, 0 @ 0x40e4e1f8
(XEN) traps.c:1759:d1v0 unhandled 32-bit cp14 access 0xa

> I would also advice you to backport the commit
> 238962ac71910d6c20162ea5230685fead1836a4 "ARM: 8191/1: decompressor: 
> ensure I-side picks up relocated code". It may help to boot further as it 
> fixes an issue with similar symptoms as yours.

I tried that, too, and it didn't seem to make any difference.

I have managed to get some more information from JTAG, although not very much 
as yet. I stepped from the eret in Xen into the new DomU VM. I saw it execute a 
branch at 0xffff0018 to 0xffff1020, and then it ran straight through to 
0xffff1048, where it did a "movs pc,lr" and ended up in __irq_svc. No idea as 
yet exactly what code it was executing (I don't have a lot of experience with 
the very early kernel boot).



Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.