[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Openindiana (was Mac OSX How-to)

On Saturday, 13 August 2016, 03:07:26 EDT, PÁSZTOR György wrote:

> Hi,


> "jim burns" <jim_burn@xxxxxxxxxxxxx> írta 2016-08-12 13:55-kor:

> > On Friday, 12 August 2016, 18:50:40 EDT, PÁSZTOR György wrote:

> > That having been said, I would be more than grateful if you care to share

> > a

> > cfg file that works.


> I do not use xen too many these days. Different workplace, different tasks.

> But in ~2013-2014 I basically followed this guide:

> http://www.itfromallangles.com/2012/01/installing-openindiana-in-a-xen-domu/


> Not word by word. Somewhere I did it in my own way.

> I just remember, that finally I liked better my own way rather then the

> result what it writes: to "copy out" the kernel, boot_archive, and another

> file to the xen host. As far as I remember, I could solve to boot my

> OI151a8 with pygrub. Then I could upgrade it inside, and the next reboot it

> was 151a9. On my servers I were never brave enough to try hipster.

> With the "hacked" version we would loose the advantages what be-s gave, so

> that's why I tried my own smart way than, to boot it with pygrub.


> So, I suggest to try it. If you stuck somewhere, do not hesitate to ask,

> and share logs/ messages on pastebin! ;-)

> Maybe I am not so rusty, to help you out! ;-)


> Cheers,

> Gyu


Yeah, that's pretty much Boris's method. When I execute the cfg for the installer, I get: (if reading this at home, make sure your email client is reading in html mode)


xl create -c oi
Parsing config from oi
libxl: warning: libxl_bootloader.c:416:bootloader_disk_attached_cb: bootloader='/usr/bin/pygrub' is deprecated; use bootloader='pygrub' instead
v4.7.0 chgset ''
SunOS Release 5.11 Version illumos-f83b46b 64-bit
Copyright (c) 1983, 2010, Oracle and/or its affiliates. All rights reserved.
Hostname: openindiana
Remounting root read/write
Probing for device nodes ...
Preparing live image for use
Done mounting Live image

panic[cpu0]/thread=ffffff00020a7c40: BAD TRAP: type=e (#pf Page fault) rp=ffffff00020a79e0 addr=50 occurred in module "xnf" due to a NULL pointer dereference

sched: #pf Page fault
Bad kernel fault at addr=0x50
pid=0, pc=0xfffffffff81868e3, sp=0xffffff00020a7ad0, eflags=0x10206
cr0: 8005003b<pg,wp,ne,et,ts,mp,pe> cr4: 2660<vmxe,xmme,fxsr,mce,pae>
cr2: 50
       rdi:                4 rsi:                0 rdx:             1237
       rcx:             1af5  r8:               15  r9:              103
       rax:             1af5 rbx: ffffff00c74b5000 rbp: ffffff00020a7b30
       r10:                1 r11: fffffffffb825d00 r12:                0
       r13: ffffff00c74b5000 r14: ffffff00c764c000 r15:               14
       fsb:                0 gsb: fffffffffbc60020  ds:               4b
        es:               4b  fs:                0  gs:              1c3
       trp:                e err:                0 rip: fffffffff81868e3
        cs:             e030 rfl:            10206 rsp: ffffff00020a7ad0
        ss:             e02b

Warning - stack not written to the dump buffer
ffffff00020a78c0 unix:die+df ()
ffffff00020a79d0 unix:trap+dd8 ()
ffffff00020a79e0 unix:_cmntrap+12b ()
ffffff00020a7b30 xnf:xnf_rx_collect+123 ()
ffffff00020a7b70 xnf:xnf_intr+48 ()
ffffff00020a7be0 unix:av_dispatch_autovect+91 ()
ffffff00020a7c20 unix:dispatch_hardint+36 ()
ffffff0002005970 unix:switch_sp_and_call+13 ()
ffffff00020059d0 unix:do_interrupt+fa ()
ffffff0002005a80 unix:xen_callback_handler+373 ()
ffffff0002005a90 unix:xen_callback+cb ()
ffffff0002005ba0 unix:__hypercall2+a ()
ffffff0002005bb0 unix:HYPERVISOR_block+10 ()
ffffff0002005bc0 unix:mach_cpu_idle+1d ()
ffffff0002005bf0 unix:cpu_idle+fe ()
ffffff0002005c00 unix:cpu_idle_adaptive+13 ()
ffffff0002005c20 unix:idle+41 ()
ffffff0002005c30 unix:thread_start+8 ()

syncing file systems... 1 1 done
skipping system dump - no dump device configured

Which is what I got before. The 'rebooting...' message is particularly annoying, as I have to give an 'xl destroy ...' command repeatedly till it stops rebooting. Thanx for the suggestion, tho'. (Altho', in hindsight, changing '_on_reboot_="restart"' to destroy might have solved that problem.)

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.