[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Xen doesn't work with Adaptec ASR-72405


Could you, please, clarify what kind of LSI controller you have changed the Adaptec with? Also, what version of the Xen hypervisor are you using, how many disks are connected and
what kind of motherboard manufacturer (model) are you using?

BR, Andrej

On 2017-04-08 02:19, Alex Wakizashi wrote:

Has reported similar problem, and also with Adaptec - about year ago...

Still not received any answer - neither here, not in xen-devel, looks
like everybody here hates Adaptec, and don't want to solve any related
issues ;)

And just recently reported it again - in relation to driver domains for XEN 4.8.

Same situation are with some Marvel SATA controllers.
And same sympthoms - working fine with bare-metal Linux, and not
working in Dom0 or DomU.

Passed through to PV DomU, it causes XEN to crash and host to reboot
if unplugged or with domain shutdown.
It happens only if aacraid driver is tried to be loaded in guest. If
aacraid not loaded - domain can be shutted down, or device unplugged
without problems.

And it also happens on Supermicro, Gigabyte and ASUS server
motherboards, single, dual and quad CPUs (Tested on wide range of

One good thing - it working fine in HVM domain with CPU affinity set
to same CPU, which PCIe slot is used for controller.
So, while it's not possible to use as "classical" storage domain, you
still can use it with iSCSI/SRP/AoE/FCoE/NBD/etc.

Meanwhile, Supermicro strongly  recommends LSI RAID controllers, and
personally, I never seen any issues with them - neither on Supermicro,
nor on other vendor's motherboards.
Supermicro even have their own firmware for LSI chips.
Intel C6xx SAS controllers also working perfectly - both in PV and PVH.

As results, have replaced all my Adaptec RAID/HBA cards with LSI ones,
with small exceptions, used for tests (and Adaptec are also very hot -
almost not possible to use without proper cooling in desktop or
convertible systems).


On 7 April 2017 at 16:20,  <domain@xxxxxxxx> wrote:


I'm trying to find out the reason of the next problem:
after Xen booting, the system can't find RAID controller Adaptec ASR-72405 and as a consequence can't find SSDs. The module (aacraid) for this type of
controller loaded. We have tried to boot with system installed
(1.2-1[41010]-ms) and with the last Adaptec driver version (1.2.1-52033)
from official site, but got the same result.

In dmesg we got few errors related with controller driver:

[ 1127.197227] aacraid: aac_fib_send: first asynchronous command timed out.
[ 1127.197227] Usually a result of a PCI interrupt routing problem;
[ 1127.197227] update mother board BIOS or consider utilizing one of
[ 1127.197227] the SAFE mode kernel options (acpi, apic etc)

But, when we have tried to boot the system without Xen, we don't have this
The system have found the controller and all connected drives.
The drivers, kernel and other parameters of system have not been changed
(the same with Xen system).

Some information about hardware and software versions:

Supermicro X10QBi, Version 3.0, Build Date 05/04/2016 12:38:52
CPUs 4x Intel (R) Xeon (R) CPU E7 -8890 v4 @ 2.20GHz
RAM 6291456 MB (DDR4 1600MHz)

Ubuntu kernel version: 4.4.0-67
Xen version: 4.6.0
RAID Controller Adaptec - 72405
Controller driver versions: 1.2-1[41010]-m, 1.2.1-52033
Controller BIOS version: BIOS: 7.5-0 (32106)
Controller Firware Version: Firmware: 7.5-0 (32106)

Xen boot log attached.
Xen-users mailing list

Xen-users mailing list

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.