[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] booting debian/stretch as EFI guest on Xen 4.9.0 host -- ​\EFI\debian\grubx64.efi "not recognized"?

On 10/17/17 9:53 AM, Robert McNicol wrote:
I've already tried the \efi\boot\bootx64.efi, and I get a fail with a complaint 
about SecureBoot -- which I've tried to disable in the TianoCore setup.  I'm 
not convinced that the disable
takes properly; haven't yet rewritten the img's NvVars directly (from earlier 
comments ...).

I bet that’s the difference with the SUSE OVMF and the DEB OVMF. Debian does 
NOT support secure boot yet.

If I

        kpartx -av /dev/VG0/deb64_ESP
        mount /dev/mapper/VG0-deb64_ESP1 /mnt/TEMP
        mount -o loop debian-9.2.0-amd64-netinst.iso /mnt/ISO
        echo "vmlinuz rw root=/dev/xvdg initrd=\initrd.gz" > 
        cp -af /mnt/ISO/install.amd/xen/{vmlinuz,initrd.gz} /mnt/TEMP/
        umount /mnt/TEMP
        kpartx -dv /dev/VG0/deb64_ESP
        umount /mnt/ISO


        xl create debian64vm_install_pvhvm.cfg

I, again, get to the EFI shell, it sees/reads the startup.nsh, and returns:

        Shell> vmlinuz rw root=/dev/xvdg initrd=\initrd.gz
        Script Error Status: Security Violation (line number 1)

What I don't yet know is that^ because

        (a) I've got the wrong string in startup.nsh

, &/or

        (b) this *is* the issue with the installer's lack of SecureBoot support

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.