[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Xen 4.1 compile from source and install on Fedora 17


and built/installed Xen from source, using grub2-mkconfig to rebuild grub and was able to reboot 
Dom0 with Xen successfully. 

Then I installed packages for virt-manager.
# yum install libvirt-daemon-xen python-virtinst libvirt-daemon-config-network libvirt-daemon-driver-network virt-manager virt-viewer
Everything got installed except for one package. Got an error message "No package libvirt-daemon-driver-network available."

Now when I start virt-manager, it is unable to connect to Xen and fails with the following error. 
# virt-manager
   Unable to connect to libvirt.

  unable to connect to 'localhost:8000': Connection refused

  Verify that:
   - A Xen host kernel was booted
   - The Xen service has been started

  Libvirt URI is: xen:///

  Traceback (most recent call last):
    File "/usr/share/virt-manager/virtManager/connection.py", line 1027, in _open_thread
     self.vmm = self._try_open()
    File "/usr/share/virt-manager/virtManager/connection.py", line 1009, in _try_open
    File "/usr/lib64/python2.7/site-packages/libvirt.py", line 102, in openAuth
      if ret is None:raise libvirtError('virConnectOpenAuth() failed')
  libvirtError: unable to connect to 'localhost:8000': Connection refused

# xm list and # xm info work fine. This means xend is running right ?

Added (xend-unix-server yes) to xen configuration file xend-config.sxp
and added export VIRSH_DEFAULT_CONNECT_URI="xen:///" to root's .bashrc. 
Still no luck.

This might help, # rpm -qa | grep libvirt

So in summary, 
Built and installed from source Xen 4.1.5, on Fedora 17. 
Can boot into Xen Dom0, xm works, xend running, But virt-manager unable to connect to Xen! 

Please help. 
I have tried to give as much info as I could. Do let me know if you need more info. 

On Wed, Jun 12, 2013 at 6:44 PM, Dario Faggioli <dario.faggioli@xxxxxxxxxx> wrote:
On mer, 2013-06-12 at 09:22 -0400, Gizmo Chicken wrote:
> Not sure if the comment is correct, but based on Comment #9 to my bug
> report, Debian/Ubuntu seems to package Xen in such a way that certain
> components (such as libxenlight.so) are installed differently compared
> to other distros.  See Comment #9 at
> https://bugs.launchpad.net/ubuntu/+source/libvirt/+bug/1180281
That is possible, I guess... I'm sorry, but as I said already, I know
nothing of using both the packaged version of Xen and libvirt on Debian
or Ubuntu. :-(

> I haven't spent much time with virt-manager on Fedora 19 beta, so I
> can't provide details.  But if I recall correctly, I also got
> something like "Unable to connect to libvirt" when attempting to use
> virt-manager with Xen and the XL toolstack.  XL was definitely
> running, and near as I could tell, XM/xend was not running.  I didn't
> try virt-manager with the XM toolstack.
Well, without the details, it's hard to say anything more than what has
been said already. I do test Xen on Fedora regularly, and that includes
basic libvirt (both virt-install and virt-manager) operations. Both
Fedora 18 and Fedora 19 work pretty well for me, and I haven't seen any
issues in connecting to libvirtd.

If you get the chance to try it again, feel free to ask for help,
providing all the needed details on what is that your are seeing, either
here, or on xen@xxxxxxxxxxxxxxxxxxxxxxx, or on
virt@xxxxxxxxxxxxxxxxxxxxxxx, or on libvir-list@xxxxxxxxxx, depending on
where you think the problem could be. :-)


<<This happens because I choose it to happen!>> (Raistlin Majere)
Dario Faggioli, Ph.D, http://about.me/dario.faggioli
Senior Software Engineer, Citrix Systems R&D Ltd., Cambridge (UK)

Ranjith krishnan
Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.