[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [Xen-devel] [PATCH 3/3] x86: Use alternative mechanism to define CLAC/STAC
> -----Original Message----- > From: Andrew Cooper [mailto:amc96@xxxxxxxxxxxxxxxx] On Behalf Of > Andrew Cooper > Sent: Monday, May 26, 2014 11:50 PM > To: Wu, Feng; xen-devel@xxxxxxxxxxxxx > Cc: keir.xen@xxxxxxxxx; JBeulich@xxxxxxxx > Subject: Re: [Xen-devel] [PATCH 3/3] x86: Use alternative mechanism to define > CLAC/STAC > > On 26/05/2014 08:27, Feng Wu wrote: > > This patch use alternative mechanism to define CLAC/STAC. > > > > Signed-off-by: Feng Wu <feng.wu@xxxxxxxxx> > > --- > > xen/include/asm-x86/asm_defns.h | 36 > +++++++++++++++++++++++------------- > > 1 file changed, 23 insertions(+), 13 deletions(-) > > > > diff --git a/xen/include/asm-x86/asm_defns.h > b/xen/include/asm-x86/asm_defns.h > > index 87a462f..92024cc 100644 > > --- a/xen/include/asm-x86/asm_defns.h > > +++ b/xen/include/asm-x86/asm_defns.h > > @@ -10,6 +10,8 @@ > > #include <asm/percpu.h> > > #include <xen/stringify.h> > > #include <asm/cpufeature.h> > > +#include <asm/nops.h> > > +#include <asm/alternative.h> > > alternatives should include nops, to avoid needing a double include > everywhere alternative() is used. > > > > > #ifndef __ASSEMBLY__ > > void ret_from_intr(void); > > @@ -166,26 +168,34 @@ void ret_from_intr(void); > > #define __ASM_STAC .byte 0x0f,0x01,0xcb > > > > #ifdef __ASSEMBLY__ > > -#define ASM_AC(op) \ > > - btl $X86_FEATURE_SMAP & 31, \ > > - > CPUINFO_FEATURE_OFFSET(X86_FEATURE_SMAP)+boot_cpu_data(%rip); \ > > - jnc 881f; \ > > - __ASM_##op; \ > > -881: > > - > > -#define ASM_STAC ASM_AC(STAC) > > -#define ASM_CLAC ASM_AC(CLAC) > > +#define ASM_CLAC > \ > > + 661: ASM_NOP3; > \ > > + .pushsection .altinstr_replacement, "ax"; > \ > > The altinstr_replacement section doesn't need to be executable. The > data inside it is copied out into the .text section. > > > + 662: __ASM_CLAC; > \ > > + .popsection; > \ > > + .pushsection .altinstructions, "a"; > \ > > + altinstruction_entry 661b, 662b, X86_FEATURE_SMAP, 3, 3; > \ > > + .popsection > > these 661s and 662s alias magic numbers in the alternatives core code, > which could lead to subtle issues. Surely there is a better way than > having to choose magic numbers which don't collide with anything else in > the source. > > ~Andrew Do you think what problems would be caused by these magic numbers? Since these macros are ported from Linux being unchanged and they have already been running for a long time, I think it should be safe enough for us to reuse here. Thanks, Feng > > > + > > +#define ASM_STAC > \ > > + 661: ASM_NOP3; > \ > > + .pushsection .altinstr_replacement, "ax"; > \ > > + 662: __ASM_STAC; > \ > > + .popsection; > \ > > + .pushsection .altinstructions, "a"; > \ > > + altinstruction_entry 661b, 662b, X86_FEATURE_SMAP, 3, 3; > \ > > + .popsection > > #else > > static inline void clac(void) > > { > > - if ( boot_cpu_has(X86_FEATURE_SMAP) ) > > - asm volatile (__stringify(__ASM_CLAC) : : : "memory"); > > + /* Note: a barrier is implicit in alternative() */ > > + alternative(ASM_NOP3, __stringify(__ASM_CLAC), > X86_FEATURE_SMAP); > > } > > > > static inline void stac(void) > > { > > - if ( boot_cpu_has(X86_FEATURE_SMAP) ) > > - asm volatile (__stringify(__ASM_STAC) : : : "memory"); > > + /* Note: a barrier is implicit in alternative() */ > > + alternative(ASM_NOP3, __stringify(__ASM_STAC), > X86_FEATURE_SMAP); > > } > > #endif > > _______________________________________________ Xen-devel mailing list Xen-devel@xxxxxxxxxxxxx http://lists.xen.org/xen-devel
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |