[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH v6 2/3] xen/arm: Enable the existing x86 virtual PCI support for ARM.

  • To: Roger Pau Monné <roger.pau@xxxxxxxxxx>
  • From: Bertrand Marquis <Bertrand.Marquis@xxxxxxx>
  • Date: Fri, 15 Oct 2021 12:13:05 +0000
  • Accept-language: en-GB, en-US
  • Arc-authentication-results: i=1; mx.microsoft.com 1; spf=pass smtp.mailfrom=arm.com; dmarc=pass action=none header.from=arm.com; dkim=pass header.d=arm.com; arc=none
  • Arc-message-signature: i=1; a=rsa-sha256; c=relaxed/relaxed; d=microsoft.com; s=arcselector9901; h=From:Date:Subject:Message-ID:Content-Type:MIME-Version:X-MS-Exchange-AntiSpam-MessageData-ChunkCount:X-MS-Exchange-AntiSpam-MessageData-0:X-MS-Exchange-AntiSpam-MessageData-1; bh=5K0K0IGkCQcCOOaFasUKhPNp1jYbyhQEBdP2gn0ExBo=; b=NkYdrdyzo1Scf0hyYWohCU6QtrKORbeIeMgjZ8NZ0hYgd0pKC8AV7ixzOeFmttXal0bduIOtsvVNChhLmehUO+yu7vn1RHt/scOW2IPb7qGw8ExB91jHsMpzifLLSfpY/dvVFXEqOBsDdEDV3o7+tEDNsAejYVAtqLGoyHT2ouSlnhG07UlWi4P8ts2QQNs9Ul+89O1KZbwf9Rq15sKB1DUuuXBUqeqQ1X96H/7IQUgZs3XTnNtj7buduC5jwj0z91aO/CXjUIp0jmhqaT3KQRwdiZA4HAydWctxxT2xTTzE/Q3V0NSsIpkZ2dAt+hD4vIwPDduQ0xcbARgg/JdcFw==
  • Arc-seal: i=1; a=rsa-sha256; s=arcselector9901; d=microsoft.com; cv=none; b=goDRff0lbISlBOdZWLlSyfuzZhIsNCUHx6MIO3Q5B3/V4GXtYDMGKotRGFSaMg8BzJWpJrYZBPd9fuW4B3Pgl0aAknhunFuB/+DCnOWRHB/ePvflVRDNFPh+TXlYxwC3qi+Ey3lyUl9CfOTWUkeiPs/GJRdFQ/XZ5YfgHDL3rlxoimcs+UjysZBrivjHZniNT2AkrtS3wOZl5SlOCkdHSFgch8R5z6FtkjvOMfbyu6iyR8eIHuT9/56D1McSF/fUlZTDx8hSiDf2jZnw/IRkCizKPGNf1hGFX7w7M8r/KYBl1XBa0OJ4hmj+hC+bh5yURNAsKDrnl+Sem6Kuc7MCqA==
  • Authentication-results-original: citrix.com; dkim=none (message not signed) header.d=none;citrix.com; dmarc=none action=none header.from=arm.com;
  • Cc: Jan Beulich <jbeulich@xxxxxxxx>, Ian Jackson <iwj@xxxxxxxxxxxxxx>, Rahul Singh <Rahul.Singh@xxxxxxx>, Stefano Stabellini <sstabellini@xxxxxxxxxx>, Julien Grall <julien@xxxxxxx>, Volodymyr Babchuk <Volodymyr_Babchuk@xxxxxxxx>, Andrew Cooper <andrew.cooper3@xxxxxxxxxx>, George Dunlap <george.dunlap@xxxxxxxxxx>, Wei Liu <wl@xxxxxxx>, Paul Durrant <paul@xxxxxxx>, "xen-devel@xxxxxxxxxxxxxxxxxxxx" <xen-devel@xxxxxxxxxxxxxxxxxxxx>
  • Delivery-date: Fri, 15 Oct 2021 12:13:33 +0000
  • List-id: Xen developer discussion <xen-devel.lists.xenproject.org>
  • Nodisclaimer: true
  • Original-authentication-results: citrix.com; dkim=none (message not signed) header.d=none;citrix.com; dmarc=none action=none header.from=arm.com;
  • Thread-index: AQHXwQrjS6mPrKT7Q06z3N66FcsDAKvTs1WAgAAj+QCAAAF1gIAAAUmAgAAVT4CAAAqRAA==
  • Thread-topic: [PATCH v6 2/3] xen/arm: Enable the existing x86 virtual PCI support for ARM.

Hi Roger,

> On 15 Oct 2021, at 12:35, Roger Pau Monné <roger.pau@xxxxxxxxxx> wrote:
> On Fri, Oct 15, 2021 at 12:18:59PM +0200, Jan Beulich wrote:
>> On 15.10.2021 12:14, Ian Jackson wrote:
>>> Bertrand Marquis writes ("Re: [PATCH v6 2/3] xen/arm: Enable the existing 
>>> x86 virtual PCI support for ARM."):
>>>>> On 15 Oct 2021, at 09:00, Jan Beulich <jbeulich@xxxxxxxx> wrote:
>>>>> The latter is fine to be put here (i.e. FTAOD I'm fine with it
>>>>> staying here). For the former I even question its original placement
>>>>> in asm-x86/pci.h: It's not generally correct as per the PCI spec, as
>>>>> the bus portion of the address can be anywhere from 1 to 8 bits. And
>>>>> in fact there is a reason why this macro was/is used in only a
>>>>> single place, but not e.g. in x86'es handling of physical MCFG. It
>>>>> is merely an implementation choice in vPCI that the entire segment 0
>>>>> has a linear address range covering all 256 buses. Hence I think
>>>>> this wants to move to xen/vpci.h and then perhaps also be named
>>>>> VPCI_ECAM_BDF().
>>>> On previous version it was request to renamed this to ECAM and agreed
>>>> to put is here. Now you want me to rename it to VPCI and move it again.
>>>> I would like to have a confirmation that this is ok and the final move if 
>>>> possible.
>>>> @Roger can you confirm this is what is wanted ?
>>> I think Roger is not available today I'm afraid.
>>> Bertrand, can you give me a link to the comment from Roger ?
>>> Assuming that it says what I think it will say:
>>> I think the best thing to do will be to leave the name as it was in
>>> the most recent version of your series.  I don't think it makes sense
>>> to block this patch over a naming disagreement.  And it would be best
>>> to minimise unnecessary churn.
>>> I would be happy to release-ack a name change (perhaps proposed bo Jan
>>> or Roger) supposing that that is the ultimate maintainer consensus.
>>> Jan, would that approach be OK with you ?
>> Well, yes, if a subsequent name change is okay, then I could live with
>> that. I'd still find it odd to rename a function immediately after it
>> already got renamed. As expressed elsewhere, I suspect in his request
>> Roger did not pay attention to a use of the function in non-ECAM code.
> Using MMCFG_BDF was original requested by Julien, not myself I think:
> https://lore.kernel.org/xen-devel/a868e1e7-8400-45df-6eaa-69f1e2c99383@xxxxxxx/
> I'm slightly loss in so many messages. On x86 we subtract the MCFG
> start address from the passed one before getting the BDF, and then we
> add the startting bus address passed in the ACPI table. This is so far
> not need on Arm AFAICT because of the fixed nature of the selected
> virtual ECAM region.

At the end my patch will add in xen/pci.h:
#define ECAM_BDF(addr)         (((addr) & 0x0ffff000) >> 12)
#define ECAM_REG_OFFSET(addr)  ((addr) & 0x00000fff)

Now seeing the comment the question is should those be renamed with a VPCI
prefix and be moved to xen/vpci.h.

So far ECAM_BDF is only used in vpci_mmcfg_decode_addr which is only called
before calling vpci_ecam_{read/write}.

ECAM_REG_OFFSET is only used in arm vpci code.

Do you think the current state is ok of the renaming + moving should be done ?




Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.