[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Installing NFS server on unprivileged domain

On Tue, 2005-05-10 at 11:04 -0700, Tom Brown wrote:
> On Tue, 10 May 2005, John A. Sullivan III wrote:
> > On Mon, 2005-05-09 at 23:57 -0700, Tom Brown wrote:
> > > > I thought that I perhaps mangled this custom kernel so I ripped it all
> > > > out and made the same changes to 2.6.10-xenU.  The same results.  So, I
> > > > tried the same for 2.6.10-xen0.  Same results.  I tried directly
> > > > editing .config to say that sunrpc should be compiled as a module.  No
> > > > change.
> > > >
> > > > What am I doing wrong? How does one install an NFS server on an
> > > > unprivileged domain? Thanks - John
> > >
> > > what does modprobe say? Did you remember to copy the modules into the
> > > appropriate /lib/modules directory in the filesystem for the xenU domain?
> > >
> > > -Tom
> > >
> > Thanks for such a quick response.  I didn't even try modprobe as there
> > was no sunrpc.ko or sunrpc.o to be found anywhere in the /lib/modules/
> > subdirectories.  I tried this morning anyway and it complained about not
> > being able to find sunrpc.
> Good, that is exactly the line of thought I wanted you to go down.
> >
> > I do notice that I have a xen-2.0/linux-2.6.10-
> > xenUNFS/net/sunrpc/sunrpc.o
> >
> > That would appear to be the necessary module but it did not install.
> > I'm hesitant to work around the installation procedure
> The installation proceedure (at least as I did it) doesn't have anything
> to do with setting up the domU filesystem, so it can't very well install
> the module for you... I built xen in my dom0 system... and there I have
> 2.4.29-xen0  2.4.29-xenU  2.6.10-xen0  2.6.10-xenU   directories in my
> /lib/modules directory... if I were in your shoes, I would tar up the
> appropriate directory and copy it to my domU filesystem... then run depmod
> and (hoping that doesn't produce any errors) then run modprobe
> -Tom
Thanks again.  I was a little skeptical since domain 0 is also failing
to find sunrpc.  Nonetheless, I copied over the entire /lib/modules
directory and the directories containing the symbolic links for source
and build.  I restarted the unprivileged domain and still have the same

What bit of magic am I missing for something so seemingly simple?

After I have reconfigured the kernel to add NFS server support, I have
not run a make, make modules or make modules_install from the kernel
directory.  Instead, I have run make and make install from the xen
parent directory.  I thought that is what one is supposed to do.  Am I
mistaken? Am I supposed to build the modules in each of the separate
kernel directories? Thanks - John
John A. Sullivan III
Open Source Development Corporation
+1 207-985-7880

If you would like to participate in the development of an open source
enterprise class network security management system, please visit

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.