[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] cannot boot any domU

  • To: Scott Koranda <skoranda@xxxxxxxxxxxxxxxxxxxx>, xen-users@xxxxxxxxxxxxxxxxxxx
  • From: Yvette Chanco <yentlsoup@xxxxxxxxx>
  • Date: Sat, 6 Aug 2005 19:38:22 -0500
  • Delivery-date: Sun, 07 Aug 2005 00:36:50 +0000
  • Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=beta; d=gmail.com; h=received:message-id:date:from:to:subject:in-reply-to:mime-version:content-type:content-transfer-encoding:content-disposition:references; b=JpeF1MH1SfhvZp9stRlu5sSbMCllHdgURdbhy9zwEkn08nw4zanCMeqbTH2W8YY5Arn7QKqpKa/BhBsdywoZP1m6F3jBwY1lIT5MkufPvWXn0nWidYgUWU6gGmyr2FgcTVDJm22Uxa7Uwyi1BPh9cnM7aKYis/ekmr13rnB7SNY=
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

On 8/6/05, Scott Koranda <skoranda@xxxxxxxxxxxxxxxxxxxx> wrote:
> /var/log/xend-debug.log has this:
> [root@garlic ~]# cat /var/log/xend-debug.log
> xfrd: error while loading shared libraries: libcurl.so.2:
> cannot open shared object file: No such file or directory
> network start bridge=xen-br0 netdev=eth0 antispoof=no
> Is the libcurl error fatal?

No... at least, I've never seen nor heard of it being fatal. xfrd is
the transfer daemon, and so if you _did_ have a domU running, that
error means you would not have been able to save, restore, and migrate

So, look on the bright side - at least you've solved that problem
before you got there (the work-around you list below is in use,
although I can't attest to how reliable it is).

> I have curl-7.12.1-1 and curl-devel-7.12.1-1 RPMs installed
> and they provide
> [root@garlic ~]# rpm -q -l curl-7.12.1-1 | grep libcurl
> /usr/lib/libcurl.so.3
> /usr/lib/libcurl.so.3.0.0
> I did the quick and (quite) dirty fix of
> ln -s /usr/lib/libcurl.so.3 /usr/lib/libcurl.so.2
> but it didn't help with booting a domU...still hangs
> immediately.
> Scott

Such an interesting problem. Not that it is any consolation to you,
but your first post reads like a howto, except for the end part ("and
then it all died"). I'm just not surehow anything you've done could
result in such a catastrophic result. Unless I'm reading it wrong (and
just to be clear), trying to start a domU with the command "xm create
mydomU.cfg -c" results in...
 *one line to the console of "Using config file "mydomU.cfg"
 *system freeze, machine non-responsive for input devices (keyboard) and network

I even tried to test "doing bad things" on my own test systems, such
as mount the swap partition twice, or wreaking havoc on the
networking, but I can't get things to fail withouth an error message
of any kind. The last time I remember seeing something like (on the
list) this was involved the e1000 driver, but that was fixed in 2.0.6.

Hopefully somebody who has seen this, been there, or is in general
more knowledable than I am will post and give you the answers you
seek, but... if I were you, really wanted to figure this out, and had
nothing but time I would try some or all of the following, in no
particular order (some of these are repeats):

1) Booting from the live CD demo (which you said you would next week)
2) Cycle through possible domU images (as you are also doing, but
there are more out there)
3) Post my hardware configuration to the list
4) Use the "Xen" initrd for Fedora Core 3
As booting isn't your issue, I don't see that as a resolution, but
it's one less thing to knock of the to-do list
5) Switch to 2.0.7 (also shouldn't matter, but what do you have to lose?)
6) Compile from source


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.