[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Solaris domU dies at boot

On Fri, May 09, 2008 at 01:45:57AM -0500, Michael Jinks wrote:
> don't know if they do anything weird with their build process or not, if
> there are any known issues that pertain to Solaris guests...  Windows
> (HVM) and Linux (PVM) domU's have both worked fine, for whatever that
> might be worth.

This prompted me to double check that other domU's still work after my
upgrade from Xen 3.2.0 to 3.2.1, and that made me realize that I didn't
have my dom0's tun/tap device loaded, something that's bitten me in the

With that in place, Solaris gets further, or appears to; the domain
sticks around according to 'xm list', but the VNC console doesn't show
up, and 'xm console' croaks:

  xenconsole: Could not read tty from store: No such file or directory

I've seen that error before while trying to boot Solaris, and googling
for it leaves me thinking that there are lots of reasons it can happen,
but for the moment I don't know what's going on in my case, and since I
can't get a console I don't know what state my domU is really in.

Funny, too, since xm console worked fine for this domU a few hours ago,
and I don't think I've changed much since then other than loading the
tun module.

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.