[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Trouble with PCI Passthrough

On Sat, Oct 6, 2012 at 3:31 PM, David Escott <david.escott@xxxxxxxxxxxxxxxx> wrote:

Not sure how to read this. Is 01.0-[01] and 01.1-[02] indicative they
are behind the switch 01.*? That would make the most sense (and be the
most frustrating... how is a consumer to know what the PCI layout of
the motherboard is until they open the box?).

You don't.  Name of the game I'm afraid, short of emailing the manufacturer you have no idea as to the actual hardware layout.  Also they are not obligated to send you that information even if you request it.  They don't cater to us crazies so much as the average user who would never need to know that level of detail.

I am not a hardware expert, in fact I can shamefully admit that almost all of my Xen related hardware knowledge was learned "by accident".

I don't "read" lspci tree output so much as use it to get a basic understanding as to the layout, I don't really follow how the numbers correspond to their BDF format.

I haven't had a chance to experiment with multiple discrete graphics cards, but I have had a motherboard where the card was behind the same switch as the onboard NIC and ended up passing both.  At the same time, my current board has devices behind a switch and I am able to pass individual components without a problem.  I am sure if you ran lspci -vvv there are flags or settings for different types of bridges that effect that specific situation, but I wouldn't know where to begin looking that information up.

-[0000:00]-+-00.0  Intel Corporation Ivy Bridge DRAM Controller
           +-01.0-[01]--+-00.0  ATI Technologies Inc RV630 [Radeon HD 2600XT]
           |            \-00.1  ATI Technologies Inc RV630/M76 audio
device [Radeon HD 2600 Series]
           +-01.1-[02]--+-00.0  ATI Technologies Inc Device 6819
           |            \-00.1  ATI Technologies Inc Device aab0

The motherboard is an MSI Z77A-G45.

I did notice your motherboard has three PCI Express slots.  Have you tried swapping which card is connected to which slot?  It may sound like a slightly less stupid suggestion now that you've checked the tree output of lspci.

I also still would recommend trying a fresh Windows 7 install, and comparing create log differences, since neither of us can prove that it is in fact the pci switch.
On Sat, Oct 6, 2012 at 2:48 PM, Casey DeLorme <cdelorme@xxxxxxxxx> wrote:
> In your situation, here are the points I would investigate:
> What model is your motherboard?  Have you used lspci -tv to see whether or
> not your cards are behind a PCI Switch perhaps?  While NF200 chips are not
> compatible, PLX seems to be, but it'll attempt to pass all devices behind
> it.
> Is it possible when you installed drivers it was only setup for the 2600?
> Have you tried a fresh installation of Windows 7, and passing just the HD
> 7850 after the installation is completed?
> Do your logs have anything special when you pass the HD 7850 solo to the
> HVM?  If you run "xl -vvv create" with one then both cards, how does the
> output differ?
> On Sat, Oct 6, 2012 at 2:34 PM, David Escott <david.escott@xxxxxxxxxxxxxxxx>
> wrote:
>> Passthrough seems to be the most common problem, but I don't know enough
>> of
>> the voodoo magic to understand where to start investigating my issue,
>> which is that passthrough works but only when passing through multiple
>> devices:
>> dom0: Fedora 17 with stock XEN (a later 4.1 version and a 3.5 kernel)
>> Hardware: VT-d capable MSI Z77 w/ i7-3770
>> Graphics cards:
>>       Intel HD 4000 IGD set as primary in the bios and used by dom0
>>       Radeon HD2600XT (from 2005ish) PCI-E slot 1, PCI 0000:01:00.[0,1]
>>       Radeon 7850 (brand new)              PCI-E slot 3, PCI
>> 0000:02:00.[0,1]
>> What works:
>>     dom0 with the HD4000 IGD
>>     domU Windows 7 when both Radeon cards are passed through
>>               ie stubbing out 0000:01:00.[0-1] and 0000:02:00.[0-1]
>> and giving both to Win7
>> What doesn't work (and what I dont understand):
>>     domU Win7 when only one of the two devices is passed to Windows
>> (in which case I get the error 43) [tried it both ways, passing only
>> the 2600 or only the 7850, and same error either way]
>> Given that passthrough works, I dont understand why it would not work
>> when I only pass one of the devices. Is there something I should be
>> looking at (DMA ranges? IRQs?) to determine what linkage there is
>> between these two devices?
>> Thanks,
>> David
>> --
>> David Wright Escott
>> A comathematician turns cotheorems into phi.
>> _______________________________________________
>> Xen-users mailing list
>> Xen-users@xxxxxxxxxxxxx
>> http://lists.xen.org/xen-users

David Wright Escott
A comathematician turns cotheorems into phi.

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.