[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] First time xen install - Xen DomU runs, but can't find "/dev/root"

OK, I have managed to get it largely working, thank you for your assistance.

- Virt-install using a CD image on a local filesystem loads the kernel and initrd correctly, but doesn't load the /root correctly from the CD. I never figured out how to do this, but /dev/xvda was the virtual disc that I was trying to install onto (and therefore was empty and wouldn't act as a root filesystem). It is possible that the --extra-args option may be used to fix this, but I have mine working now and am unlikely to spend too much more time trying.

- I managed to install it by setting up a web server on another machine, and mounted the install CD into the web server's /var/www/html/f18 directory. Thank you Dario for the references to the test day where all their installs were via the network (although they use PXE, which I have no experience in) - I tried this after noticing that the pros didn't use the local filesystems for installs.

- 256MB of RAM is insufficient to install F18 in text mode. I had to increase it to 512MB. With 256MB I was getting pages of out of memory errors and the install would fail.

- One of the first things I tried was the --cdrom option, however this requires HVM which my current CPU does not support.

- I am still having issues with the xl toolchain. Firstly, when used to install, it would bomb out with an error when it went to connect to the new console (immediately connecting to the console manually would work). Secondly it wouldn't recognise DomUs as being deleted and would not allow me to recreate them "ERROR Guest name 'xen1' is already in use.". If I manually started xend, both of these problems would disappear without changing the virt-install command. Maybe if I updated my software then this problem would go away (unfortunately this machine doesn't have a direct connection to the internet - hence me using install DVD images rather than remote URLs).

- For the record, the command I used to install successfully from the console was virt-install --paravirt --name xen1 --ram 512 --vcpus 1 -f /dev/fedora_dhcp1/xen1 --network bridge=br0 --location http://www.example.com/f18 --graphics none

Thanks all for your help - you've now got me to a stage where I can 'fiddle' around myself.

Thank you

Graham Crowe

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.