[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] VGA Passthrough with Xen 4.3 and Qemu 1.7 on Debian Jessie

Hash: SHA1


>> You should have a disk

no need, as the bios is not started and thus no disk is being accessed
(or tried to).

> The default qemu in 4.3 should be upstream, but a lot of people
> have had better luck with traditional for higher memory (myself
> included).

>> Is there a reason you are overriding the qemu device model?
>> AFAIK this is not a needed step, it should be able to get that by
>> default.

If I don't use any device_model overrides, I'll get this error:

libxl: error: libxl_dm.c:1142:libxl__spawn_local_dm: device model
/usr/lib/xen-4.3/bin/qemu-dm is not executable: No such file or directory

Qemu isn't shipped anymore with Debian or Xen itself since 4.2 [1]

> The hardware worked 18 month with VGA passthrough, so I would
> exclude it as cause, as well.
> I wouldn't entirely rule it out, were you using 4.1 on Jessie, or
> a
>> previous debian?  The way hardware is addressed by the kernel may
>> have changed, so knowing the model might help.

I did no kernel upgrade when updating Xen, just Xen (and some
unrelated stuff), just checked my dpkg.log

>> I don't see anything that stands out.  Your devices are bound to
>> pciback, though the kernel config shows the backend drivers are
>> as modules.  The xl output doesn't appear to explain the problem
>> either.  Have you tried traditional without the override?

I tried traditional with qemu-dm from xen-utils 4.1 (cf. above) and I
can get Windows to boot but all devices I passed through are not
working (errors 10 and 43, cf. my original post)


[1] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=688311
Version: GnuPG v1.4.15 (GNU/Linux)
Comment: Using GnuPG with Icedove - http://www.enigmail.net/


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.