[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] VGA Passthrough with Xen 4.3 and Qemu 1.7 on Debian Jessie

>> You should have a disk

no need, as the bios is not started and thus no disk is being accessed
(or tried to).

My mistake, you are right. ÂI tested but forgot to remove that sentence from my reply.

> The default qemu in 4.3 should be upstream, but a lot of people
> have had better luck with traditional for higher memory (myself
> included).

>> Is there a reason you are overriding the qemu device model?
>> AFAIK this is not a needed step, it should be able to get that by
>> default.

If I don't use any device_model overrides, I'll get this error:

libxl: error: libxl_dm.c:1142:libxl__spawn_local_dm: device model
/usr/lib/xen-4.3/bin/qemu-dm is not executable: No such file or directory

Qemu isn't shipped anymore with Debian or Xen itself since 4.2 [1]

That may be the problem then. ÂI built xen from source, which builds qemu. ÂI would recommend building from source instead. ÂJessie is in testing, so it's not uncommon for packages to be incomplete or misconfigured.

> The hardware worked 18 month with VGA passthrough, so I would
> exclude it as cause, as well.
> I wouldn't entirely rule it out, were you using 4.1 on Jessie, or
> a
>> previous debian? ÂThe way hardware is addressed by the kernel may
>> have changed, so knowing the model might help.

I did no kernel upgrade when updating Xen, just Xen (and some
unrelated stuff), just checked my dpkg.log

Yes, the default kernel has them set as modules. ÂI build a kernel for xen, with all related flags set to on. ÂSupposedly you can do this easily to the existing kernel with `mkinitramfs`, but I have never tried that method.

The fact that your devices are bound to pciback would suggest that things are working fine though.
>> I don't see anything that stands out. ÂYour devices are bound to
>> pciback, though the kernel config shows the backend drivers are
>> as modules. ÂThe xl output doesn't appear to explain the problem
>> either. ÂHave you tried traditional without the override?

I tried traditional with qemu-dm from xen-utils 4.1 (cf. above) and I
can get Windows to boot but all devices I passed through are not
working (errors 10 and 43, cf. my original post)

Yeah, 4.1 to 4.3 is a major jump. ÂThe code that lets xen interface with the custom qemu has changed, I'm more surprised that it loaded than that it didn't load pci devices.

I would remove the xen packages and try building it from source. ÂAt least until Jessie gets closer to a stable release.
Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.