[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Latest Arndale Xen, dom0 kernel stuck on ASIX mac.

On 7 June 2013 22:56, Julien Grall <julien.grall@xxxxxxxxxx> wrote:
> On 7 June 2013 21:35, Sander Bogaert <sander.bogaert@xxxxxxxxxxxxx> wrote:
>> On 7 June 2013 22:25, Julien Grall <julien.grall@xxxxxxxxxx> wrote:
>>> On 7 June 2013 20:58, Sander Bogaert <sander.bogaert@xxxxxxxxxxxxx> wrote:
>>>> # xl list
>>>> xc: error: Could not obtain handle on privileged command interface (2
>>>> = No such file or directory): Internal error
>>>> libxl: error: libxl.c:94:libxl_ctx_alloc: cannot open libxc handle: No
>>>> such file or directory
>>>> cannot init xl context
>>>> The solutions suggested by googling didn't do the trick. Am I supposed
>>>> to get newer tools? There is no /proc/xen so no privcmd interface I
>>>> guess..
>>> The xencommons initscript should mount /proc/xen. What happens if you
>>> try to mount manually?
>>> mount -t xenfs xen /proc/xen
>> I tried that, it doesn't exist. To be exact:
>> mount: mount point /proc/xen does not exist
> You are right,  I have a mismatch between my .config and
> arndale_xen_dom0_defconfig.
> I updated my branch linaro-3.10 with the cpufreq patch and add XENFS
> in the configuration
> file.

Again no luck. Tried some different kernel config options to in order to fix it.

First time around still proc related I guess (hangs after):

warning: failed to read mtab
warning: failed to read mtab
mount: can't find /run in /etc/fstab or /etc/mtab
warning: failed to read mtab
Segmentation fault
warning: failed to read mtab
mount: can't find /run/shm in /etc/fstab or /etc/mtab
[warn] Filesystem type 'devpts' is not supported. Skipping mount. ... (warning).
/etc/init.d/mtab.sh: 48: /etc/init.d/mtab.sh: cannot open
/proc/mounts: No such file
[ ok ] Mounting local filesystems...done.
[ ok ] Activating swapfile swap...done.
df: Warning: cannot read table of mounted file systems: No such file
or directory
[....] Setting kernel variables ...[....] Cleaning up temporary files...

Added to fstab: proc /proc proc rw,nosuid,nodev,noexec,relatime 0 0

Segmentation fault
[ ok ] Starting enhanced syslogd: rsyslogd[....] Starting periodic
command scheduler: cron.
[ ok ] Starting OpenBSD Secure Shell server: sshd.
[FAIL] startpar: service(s) returned failure: rsyslog ... failed!

Now /proc is empty and hostname gone ( like before ). Rebooted to get
a boot without the segfault ( guessing this is the know problem with
Xen atm ), same issue.

I tried this with non modular kernel config ( don't think I had them
before ) and with modules, doesn't make a difference.


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.