[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] First time xen install - Xen DomU runs, but can't find "/dev/root"

On mer, 2013-10-23 at 22:22 +1100, GC wrote:
> Okay, I've done a bit of playing around and I think I've solved most of 
> my issues...

> - xend keeps a record of its DomU domains in 
> /var/lib/xend/domains/<UUID>/config.sxp - This is why it remembers them 
> over reboots (and when the domains are stopped).
Yep, that's what I was also trying to say in my previous e-mail.

> - To convert these to a format that "xl create" can use, I used the 
> following (note that I had to have xend running to do this).
> # virsh domxml-from-native xen-sxpr config.sxp > xen1.xml
> # virsh domxml-to-native xen-xm xen1.xml > xen1.cfg
> # xl create xen1.cfg
> - I can now start and stop my DomUs using xl (without xend running) :)
Ok. Well, yes, I appreciate that this does the trick. Since (I think)
you have the domain managed by libvirt already (try `virsh list --all'
to verify that), you probably can do something like the following

# virsh domxml-to-native xen-xm xen1 > xen1.cfg

This gives you a config file suitable for xm/xend, which, hopefully, is
similar enough to the one you need for xl. So, I'm glad it work, but I
nevertheless think we need something like "domxml-to-native xen-xl" in

> - I have now found the "virsh undefine" command which has resolved my 
> "DomU already in use error" (I had been using "xl" instead of "virsh").

> My one remaining problem without xend running is that it bombs out when 
> connecting to the console when using virt-install. Below is the output 
> when I install with xend not running. If I run the exact same command 
> with xend running then I don't get the error message and it jumps 
> straight into the console. This isn't a major problem as I can simply 
> connect to the console after it bombs out.
> [root@dhcp1 ~]# virt-install --paravirt --name xen2 --ram 512 --vcpus 1 
> -f /dev/fedora_dhcp1/xen2 --network bridge=br0 --location 
> http://www.example.com/f18 --graphics none
> Starting install...
> Retrieving file .treeinfo... | 2.4 kB  00:00:00 !!!
> Retrieving file vmlinuz-PAE... | 9.3 MB  00:00:00 !!!
> Retrieving file initrd-PAE.img... |  52 MB  00:00:03 !!!
> Creating domain... |    0 B  00:00:13
> Connected to domain xen2
> Escape character is ^]
> error: this function is not supported by the connection driver: 
> virDomainOpenConsole
Mmm... Weird. Although I think there are some issues with console
support in the libvirt libxl driver (which used to work, but still...),
installation with '--graphics none' worked for me (as I wrote in the
blog post).

I'll investigate more.

Thanks and Regards,

<<This happens because I choose it to happen!>> (Raistlin Majere)
Dario Faggioli, Ph.D, http://about.me/dario.faggioli
Senior Software Engineer, Citrix Systems R&D Ltd., Cambridge (UK)

Attachment: signature.asc
Description: This is a digitally signed message part

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.