[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] GTX 670 Tips?

That sounds like the PCI ID instability I was talking about. You cannot just remove the resistors. You have to either replace them or mod the firmware straps to compensate for the instability.

The device is detected as a GK104 by Linux, but the driver doesn't know device ID of 0x11af so it doesn't work. Nouveau is more tolerant of dodgy device IDs.


On 10/27/2013 05:50 PM, Casey DeLorme wrote:
I think I just found out the reason.

00:06.0 VGA compatible controller: NVIDIA Corporation Device 11af (rev a1)
00:07.0 Audio device: NVIDIA Corporation GK104 HDMI Audio Controller
(rev a1)

I was reading this as GK104 for the video, but apparently the audio
component has the right model, and the video component is something
totally different.  Not sure if this is due to the modifications or a
glitch with passthrough, because the host machine definitely sees it as
a GK104.

On Sun, Oct 27, 2013 at 1:39 PM, Casey DeLorme <cdelorme@xxxxxxxxx
<mailto:cdelorme@xxxxxxxxx>> wrote:

        I installed Ubuntu 12.04 yesterday and Linux mint 15 a couple
        weeks ago using my card hard-moded to GRID K2 and it works
        perfectly with NVIDIA drivers.

    I was trying with Debian, which Ubuntu stems from (and mint too).  I
    am going to try Ubuntu next.

        You have to

        - install Linux
        - black list nouveau ( info provided below)
        - install NVIDIA drivers and


        a) Content of my shell script to start domU could be found here

        You may have to update those lines

        declare -r PCIdevices="0000:01:00.0 0000:01:00.1 0000:00:1a.0
        # The list of PCI devices which are to be re-enabled.
        declare -r EnableDevices="0000:01:00.0 0000:01:00.1";

        I am not the original author of this script. You can find the
        original script at ftp://ftp.enjellic.com/pub/xen/run-passthrough.

        b) Content of my domU conf file is there

    No dice, I tried your config and if I add `gfx_passthru=1` my system
    never loads.  When I check the status with either VNC or SDL both
    sit at a black screen with "serial0 console".

        Here is what I did for Ubuntu (may works for any Linux distro)

        1.  While installing set gfx_passthru=0. You need to install
        Ubuntu from another PC through usual VNC (xen)
        vnc hostname_of_your_dom0

        2. Once Ubuntu is installed you are asked to reboot. Click on
        button 'Restart'. There might be several glitches on the
        screen...Just press 'ENTER'...There might be a printed message
        asking to click on 'ENTER' but due to glitches on the screen it
        is a bit hard to guess that you are asked to press 'ENTER'. Just
        press 'ENTER'

        3. Once domU is restarted. Log in your domU using VNC from your
        other PC. Blacklist nouveau.

        sudo su
        echo "blacklist nouveau" >> /etc/modprobe.d/blacklist-nouveau.conf

        apt-get update
        apt-get install vim openssh-server

        vim /etc/default/grub

        GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
        GRUB_CMDLINE_LINUX_DEFAULT="quiet nouveau.blacklist=1 splash"


        update-initramfs -u


        Once domU is rebooted
        log into your domU through ssh

        ssh IP_of_your_domU

        stop X
        service lightdm stop # Ubuntu 12.04
        service mdm stop # Linux mint 15

        download nvidia driver
        # 32 bit
        # 64 bit

        Install it

        chmod +x NVIDIA????.run

        Once done, power off the domU


        Log into your dom0, set gfx_passthru=1

        restart your domU.

        It works for NVIDIA drivers serie 319.XX

    I tried following these steps with my system and ended on the same
    problem.  X doesn't load, xrandr "can't open display", and nothing
    shows up on screen.


    I usually stick to a minimalist gnome3 install, since I don't need
    all the software the default package comes with.  However, I decided
    to try installing the whole set during a fresh system installation.

    Post-install (nouveau) I was greeted by a functioning gdm3 and was
    able to login, but it went to fallback mode since nouveau doesn't
    support 3D Accel that Gnome3 depends on.

    I proceeded to follow your instructions (minux the gfx_passthru flag
    which is preventing any booting from happening), and I get no video

    I can access with ssh.  I think this means it's loaded:

         root@debian:~# lsmod | grep nv
         nvidia               9401892  0
         i2c_core               23876  3 i2c_piix4,videodev,nvidia

    I think this also means the card is "supposed" to be using it:

         root@debian:~# lspci -k
         00:06.0 VGA compatible controller: NVIDIA Corporation Device
    11af (rev a1)
             Subsystem: Micro-Star International Co., Ltd. Device 2840
             Kernel driver in use: nvidia
         00:07.0 Audio device: NVIDIA Corporation GK104 HDMI Audio
    Controller (rev a1)
             Subsystem: Micro-Star International Co., Ltd. Device 2840
             Kernel driver in use: snd_hda_intel

    I still get "Can't open display":

         root@debian:~# xrandr
         Can't open display

    My system generates six Xorg log files numbered Xorg.#.log starting
    at 0.  I have attached the first (they appear to have the same


    I am going to try an Ubuntu install next and see if I get any
    further.  However, if there are any ideas as to what went wrong I'd
    love to get debian working.

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.